Connectivity issues
Incident Report for Tresorit
Resolved
This incident has been resolved.
Posted May 20, 2021 - 07:40 UTC
Monitoring
Our DNS provider had a global issue affecting all services by our cloud provider, we are constantly monitoring if the fix implemented by them resolved the issue for our users.
Posted May 20, 2021 - 07:20 UTC
Investigating
We are experiencing connectivity issues due to a partial outage at our DNS provider that may affect some of our customers. We are investigating the issue further.
Posted May 20, 2021 - 07:06 UTC
This incident affected: Desktop applications, Mobile applications, Web client, Link-based sharing, and Website & payments.