eSign issues

Incident Report for Tresorit

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 11:03 UTC

Identified

The issue has been identified, the engineering is working on it.
Posted Apr 02, 2026 - 06:30 UTC

Investigating

Due to a 3rd party misconfiguration, the feature is partially not available.
Posted Apr 01, 2026 - 22:00 UTC
This incident affected: Desktop applications, Mobile applications, and Web client.