tresorit.com website is down

Incident Report for Tresorit

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 21:00 UTC

Investigating

tresorit.com is unavailable, engineering team is investigating. Web client and native apps are not affected.
Posted Dec 17, 2025 - 19:45 UTC
This incident affected: Website & payments.