Error when uploading via browser
Incident Report for Tresorit
Resolved
This incident has been resolved. In case you still experience any error, please let us know.
Posted 5 months ago. Jan 28, 2019 - 16:40 UTC
Identified
The issue has been identified and we are working hard on the solution.
Possible workaround: please upload via the mobile/desktop applications
Posted 5 months ago. Jan 28, 2019 - 13:05 UTC