Upstream service provider issues
Incident Report for Tresorit
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 17, 2019 - 14:07 UTC
Monitoring
Visitors and Tresorit customers could not access Tresorit.com, the Web Access, Send and Tresorit Path due to upstream service provider issues (HTTP Error 503. The service is unavailable).
The service wasn't available from 13:08 - 13:40 CET. We are currently monitoring the availability.
Posted about 1 month ago. Jun 17, 2019 - 11:51 UTC