Tresorit desktop and mobile apps - partial outage

Incident Report for Tresorit

Resolved

A fix has been applied, and we are monitoring the results.
Posted 4 years ago. Oct 14, 2020 - 12:35 UTC

Investigating

A few of our users might experience problems with accessing their files through the desktop and mobile apps. We are investigating this issue at the moment and will keep you updated.
Posted 4 years ago. Oct 14, 2020 - 12:25 UTC