The scheduled maintenance has been completed. As expected we did not notice any disturbance in our service.
Posted Jul 20, 2020 - 06:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2020 - 06:02 UTC
Scheduled
As part of an ongoing network infrastructure upgrade this weekend we will disable DNSSEC for our tresorit.com domain. We do not expect any disturbance in our services.